Slow load times
Incident Report for Heymarket
Resolved
This incident has been resolved.
Posted Oct 19, 2023 - 14:25 PDT
Identified
We are experiencing slow load times on some pages. The team is working on a resolution .
Posted Oct 19, 2023 - 12:50 PDT
This incident affected: Web App (app.heymarket.com).