Heymarket.com down due to Cloudfare outage

Incident Report for Heymarket

Resolved

This incident has been resolved.
Posted Jun 12, 2025 - 13:22 PDT

Monitoring

Cloudflare is currently investigating an outage that is preventing Heymarket.com’s marketing site from loading.
https://www.cloudflarestatus.com/incidents/25r9t0vz99rp
Posted Jun 12, 2025 - 12:05 PDT